ACM初级: A+B for Input-Output Practice (VI)

题目描述

Your task is to calculate the sum of some integers.

输入格式

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

输出格式

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

样例输入

4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

解题思路
                c++训练,由于不知道数据要输入多少行,无法用for循环进行控制要测试的行数目,也莫得结束条件,经过分析,这是oj系统中的一个坑,其实是有结束条件的,就类似于c语言中的EOF,利用cin写再while循环中,就可以实现控制结束条件的了(cin失败返回false)

#include<bits/stdc++.h>
using namespace std;


int main ()
{
    int n;
    while(cin>>n){//关键代码就是这行哦
		 int sum=0;
    	int t;
        for (int j=0;j<n;j++){
            cin>>t;
            sum+=t;
        }
        cout<<sum<<endl;
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值