分段函数

分段函数

有一个函数
y={ x x<1
2x-1 1<=x<10
3x-11 x>=10
写一段程序,输入x,输出y

样例输入
14.0
样例输出
31.00

import java.text.DecimalFormat;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner input = new Scanner(System.in);
  double x , y = 0;
  while(input.hasNext()) {
   x = input.nextDouble();
   if(x < 1) 
    y = x;
   else if(x >= 1 && x < 10)
    y = 2 * x - 1;
   else if(x >= 10)
    y = 3 * x - 11;
   DecimalFormat format = new DecimalFormat("0.00");
   System.out.println(format.format(y));
  }
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值