POJ 1026 Cipher(置换+循环节)

Cipher
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22366 Accepted: 6187

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


题意:给你n个数,a[i]代表第i个数要换到a[i]位置上,然后若干次数询问,每次询问一个整数k,代表要置换的次数,

一个字符串,代表置换的目标,若字符串的长度小于n,往后补空格,然后问你每次询问后的字符串的样子。

题解:简单的置换题,了解置换群的概念的话,很容易想到,就是求若干个循环节,一个循环节中的所有字符的置换是不会

影响其他字符的,所有我们分别对每个循环节中的字符进行模拟置换就行了,循环的次数是k%当前循环节长度。

#include<set>      
#include<map>         
#include<stack>                
#include<queue>                
#include<vector>        
#include<string>     
#include<time.h>    
#include<math.h>                
#include<stdio.h>                
#include<iostream>                
#include<string.h>                
#include<stdlib.h>        
#include<algorithm>       
#include<functional>        
using namespace std;                
#define ll long long          
#define inf 1000000000         
#define mod 1000000007             
#define maxn  505    
#define lowbit(x) (x&-x)                
#define eps 1e-9 
char s[maxn],s1[maxn];
int a[maxn],b[maxn],c[maxn];
int main(void)
{
	int n,m,i,j,k,num,len;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		while(scanf("%d",&k),k!=0)
		{
			getchar();
			gets(s+1);
			len=strlen(s+1);
			for(i=len+1;i<=n;i++)
				s[i]=' ';
			s[n+1]='\0';
			memset(b,0,sizeof(b));
			for(i=1;i<=n;i++)
			{
				if(b[i])
					continue;
				num=0;
				memset(c,0,sizeof(c));
				b[i]=1;c[i]=1;
				j=a[i];num=1;
				while(j!=i)
				{
					num++;
					b[j]=1;
					c[j]=1;
					j=a[j];
				}
				int kk=k%num,h=i;
				for(j=1;j<=kk;j++)
				{
					for(h=1;h<=n;h++)
						if(c[h])
							s1[h]=s[h];
					int last=i;h=a[i];
					while(h!=i)
					{
						s[h]=s1[last];
						last=h;h=a[h];
					}
					s[h]=s1[last];
				}
			}
			printf("%s\n",s+1);
		}
		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值