POJ 2566-Bound Found(尺取)

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5078 Accepted: 1617 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

题意:给你n个数,让你找一个子区间使得该子区间之和的绝对值和t的差尽可能小,输出该区间的和,以及区间的左右端点。

题解:因为数组中的数有正有负,故不满足尺取单调性的要求,我们可以考虑求前缀和,因为两个前缀和相减对应的是任意一个区间的和,因为有绝对值,所以不用考虑端点的先后顺序,我们将所有前缀和从小到大排序,然后按照尺取遍历即可。

#include<math.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int a[100005],l,r,n,k;
ll sm,ans,t;
ll abss(ll x)
{
	if(x<0)
		x=-x;
	return x;
}
struct node
{
	ll s,p;
}sum[100005];
bool comp(node a,node b)
{
	return a.s<b.s;
}
int main(void)
{
	int i;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		if(n==0 && k==0)
			break;
		sum[0].p=sum[0].s=0;
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]),sum[i].s=sum[i-1].s+a[i],sum[i].p=i;
		sort(sum,sum+n+1,comp);
		while(k--)
		{
			ans=1000000000000000;
			scanf("%lld",&t);
			l=0;r=1; ll ans1; int ls,rs;
			while(l<=n && r<=n)
			{
				ll tmp=abss(sum[l].s-sum[r].s);
				ll tmp1=abss(tmp-t);
				if(tmp1<ans)
				{
					ans=tmp1;
					ans1=tmp;
					ls=sum[l].p;
					rs=sum[r].p;
				}
				if(tmp>t) l++;
				else if(tmp<t) r++;
				else break;
				if(l==r) r++;
			}
			if(ls>rs) swap(ls,rs);
			printf("%lld %d %d\n",ans1,ls+1,rs);
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值