1022 Digital Library 数字图书馆

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

代码 

#include <iostream>
#include <set>
#include <sstream>
#include <vector>
#include <algorithm>
using namespace std;

struct Book{
    string id;
    string title;
    string author;
    set<string> keywords;
    string publisher;
    string year;
};
vector<Book> books;

int main(){
    int n;
    cin >> n;
    getchar();
    while(n--){
        string id, title, author, row_keyword, publisher, year;
        set<string> keywords;
        getline(cin, id);
        getline(cin, title);
        getline(cin, author);
        getline(cin, row_keyword);
        getline(cin, publisher);
        getline(cin, year);
        stringstream  ssin(row_keyword);
        string keyword;
        while(ssin >> keyword) keywords.insert(keyword);
        books.push_back({id, title, author, keywords, publisher, year});
    }
    
    int m;
    cin >> m;
    getchar();
    while(m--){
        string order;
        getline(cin, order);
        cout << order << endl;
        string order_key = order.substr(3);
        int order_index =order[0] - '0';
        vector<string> ids;
        switch(order_index){
            case 1:{
                for(auto &item : books)
                    if(item.title == order_key) ids.push_back(item.id);
                break;
            }
            case 2:{
                for(auto &item : books)
                    if(item.author == order_key) ids.push_back(item.id);
                break;
            }
            case 3:{
                for(auto &item : books)
                    if(item.keywords.count(order_key)) ids.push_back(item.id);
                break;
            }
            case 4:{
                for(auto &item : books)
                    if(item.publisher == order_key) ids.push_back(item.id);
                break;
            }
            case 5:{
                for(auto &item : books)
                    if(item.year == order_key) ids.push_back(item.id);
                break;
            }
            default:{
                break;
            }
        }
        if(!ids.size()) puts("Not Found");
        else{
            sort(ids.begin(), ids.end());
            for(auto id : ids){
                cout << id << endl;
            }
        }
    }
    return 0;
}

 总结

1. 一道简单的模拟题,只是输入较为繁琐。总结输入规律就是如果要使用getline(),注意先用getchar()清除回车。

2. 为什么设计结构体,因为本题数据不统一,有set和string结构并用,所以采用结构体会比较合适。

3. 如何不用编写函数分隔字符串的空格?

引入<sstream>流式字符串,定义流式输入 stringstream ssin(keywords) ,就把带空格的keywords字符串传入到流式输入ssin变量中,只需要使用ssin >> keyword,就能按照空格分隔依次读取各个keyword。代码中是将其存入set中。

4. 集合中是否存在某元素方法:count(item)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值