1025 PAT Ranking

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

const int Max = 110;
struct Student
{
    string id;
    int grade;
    int location;
    int f_rank;
    int l_rank;
    bool operator< (const Student& t) const
    {
        if(grade != t.grade) return grade > t.grade;
        return id < t.id;
    }
};

vector<Student> location[Max];  // 各个地区按数组划分的成绩记录
vector<Student> all;            // 全部的成绩记录

void set_rank(vector<Student>& item, int rank_type)     // 1:local; 2:final
{
    sort(item.begin(), item.end());
    for(int i = 0; i < item.size(); i++)
    {
        if(!i || item[i-1].grade != item[i].grade) 
            if(rank_type == 1) item[i].l_rank = i + 1;
            else item[i].f_rank = i + 1;
        else
            if(rank_type == 1) item[i].l_rank = item[i-1].l_rank;
            else item[i].f_rank = item[i-1].f_rank;
    }
}

int main()
{
    int N;
    cin >> N;
    for(int i = 1; i <= N; i++)
    {
        int K;
        cin >> K;
        for(int j = 0; j < K; j++)
        {
            string id;
            int grade;
            cin >> id >> grade;
            location[i].push_back({id, grade, i});
        }
        set_rank(location[i],1);
        all.insert(all.end(), location[i].begin(), location[i].end());
    }
    set_rank(all,2);
    
    cout << all.size() << endl;
    for(auto& i : all)
    {
        cout << i.id << ' ' << i.f_rank << ' ' << i.location << ' ' << i.l_rank << endl;
    }
    return 0;
}

总结

1. 排序的重载运算符应用,直接改变了排序比较的条件

重载运算符

2. 同分排名函数的设计:如果不同分(包括前面没人这情况),取下标+1。同分,取前面的人的排名。

3. vector的insert函数,支持vector合并,参数分别是前尾、拼接头、拼接尾

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值