PTA数据结构-01-复杂度2 Maximum Subsequence Sum

一、题目

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

二、解答 

import java.util.Scanner;

//21:40
public class Main {
    public static void main(String[] args) {
        //get arrs
        Scanner sc = new Scanner(System.in);
        String lenStr = sc.nextLine();
        String arrsStr = sc.nextLine();
        sc.close();

        //processing arrs
        int len = Integer.parseInt(lenStr.trim());
        int[] arrs = new int[len];
        String[] arrsStrs = arrsStr.split(" ");
        for (int i = 0; i < len; i++) {arrs[i] = Integer.parseInt(arrsStrs[i].trim());}

        //start to end
        printArrs(getMaxSubSeqSum(arrs));

    }
    public static int[] getMaxSubSeqSum(int[] arrs){
        int tempFirst = arrs[0];
        int tempLast = tempFirst;
        int tempSum = tempFirst;
        int maxSum = tempFirst < 0 ? -1 : tempFirst;
        int maxFirst = tempFirst;
        int maxLast = tempFirst;

        for (int i = 1; i < arrs.length; i++) {
            if (tempSum < 0) {
                tempFirst = arrs[i];
                tempSum = tempFirst;
            } else {
                tempLast = arrs[i];
                tempSum += tempLast;
            }
            if (tempSum > maxSum) {
                maxSum = tempSum;
                maxFirst = tempFirst;
                maxLast = tempFirst > tempLast ? tempFirst : tempLast;
            }
        }

        int[] result;
        if (maxSum < 0) result = new int[]{0, arrs[0], arrs[arrs.length-1]};
        else result = new int[]{maxSum, maxFirst, maxLast};
        return result;
    }
    public static void printArrs (int[] arrs){
        String result = "";
        for (int arr : arrs) {
            result += arr + " ";
        }
        System.out.println(result.trim());
    }
}
  1. 比起第一题,多了很多细节上的坑,注意:①-1,0,-1  ②-1,1,-1  ③题干到底要求输出什么
  2. 借鉴了别人的解题方式,分成多个子函数,代码更清晰
  3. 字符串的切分split()函数相关知识点需要整理补充
  4. 字符串去首尾空格用trim()
  5. 提交时出错提示关键字:最大N    修改:将输入sc.nextInt()改为sc.nextLine()并存为数组后进行处理。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值