ZOJ.2358 Sum of Factorials【略坑】 2015/10/12

Sum of Factorials

Time Limit: 2 Seconds      Memory Limit: 65536 KB

John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics, meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944).

There are some numbers which can be expressed by the sum of factorials. For example 9, 9 = 1! + 2! + 3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum of some factorials.

Well, it's just a piece of cake. For a given n, you'll check if there are some xi, and let n equal to SUM{xi!} (1 <= i <= t, t >= 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say "YES"; otherwise, print out "NO".


Input

You will get several non-negative integer n (n <= 1,000,000) from input. Each one is in a line by itself.

The input is terminated by a line with a negative integer.


Output

For each n, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.


Sample Input

9
-1


Sample Output

YES


Source: Asia 2003, Guangzhou (Mainland China)

判断n是否是几个数的阶乘之和,注意0,如果输入是0,输出NO,判断几个数的阶乘时要考虑0!

#include<iostream>
#include<cstdio>

using namespace std;

int per[10];

void init(){
    per[0] = 1;
    for( int i = 1 ; i < 10 ; ++i ){
        per[i] = per[i-1] * i;
    }
}

int main(){
    init();
    int n;
    while( ~scanf("%d",&n) ){
        if( n < 0 )
            break;
        if( n == 0 ){
            printf("NO\n");
            continue;
        }
        for( int i = 9 ; i >= 0 ; --i ){
            if( n >= per[i] ){
                n -= per[i];
            }
        }
        if( n == 0 )
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值