Poj.1730 Perfect Pth Powers【数学】 2015/11/13

Perfect Pth Powers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17232 Accepted: 3946

Description

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2

Source

不明所以,为何要加0.1???
#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#define eps 1e-6

using namespace std;

int main(){
    int n,t,p;
    while( ~scanf("%d",&n) ){
        if( n == 1 || n == -1 ) continue;
        if( n == 0 ) break;
        if( n > 0 ){
            for( int i = 31 ; i >= 1 ; --i ){
                t = (int)(pow(1.0*n,1.0/i)+0.1);
                p = (int)(pow(1.0*t,1.0*i)+0.1);
                if( n == p ){
                    printf("%d\n",i);
                    break;
                }
            }
        }
        else{
            n = -n;
            for( int i = 31 ; i >= 1 ; i-=2 ){
                t = (int)(pow(1.0*n,1.0/i)+0.1);
                p = (int)(pow(1.0*t,1.0*i)+0.1);
                if( n == p ){
                    printf("%d\n",i);
                    break;
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值