完美平方数

We say that x is a perfect square if, for some integer b, x = b 2 . Similarly, x is a perfect cube if, for some integer b, x = b 3 . More generally, x is a perfect pth power if, for some integer b, x = b p . Given an integer x you are to determine the largest p such that x is a perfect pth power. Input Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing ‘0’ follows the last test case.

Output For each test case, output a line giving the largest integer p such that x is a perfect pth power.

Sample Input

17

1073741824

25

0

Sample Output

1

30

2

对于一些整数b,n = b^p,(b为正整数)若p最大时,n为完美平方数,给出一个数n,求使n为完美平方数时,最大的p值

完全平方数的因子个数为奇数。

思路:p从31到1遍历,求n的p次开方,转为int型的t,再求t的p次方,转为int型的x

若x和n相等,则求得的p为最大值。

注意:求n的p次开方用pow()求,因为pow()函数得到的为double型,double型数据注意精度问题。

忘记了n为负数的时候,p不可能为奇数,所以循环时减2,导致wa了一次。

#include <bits/stdc++.h>
using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n)
    {
        if(n>0)
        {
            for(int i=31;i>=1;i--)
            {
                int t=pow(n*1.0,1.0/i)+0.1;
                int x=pow(t*1.0,1.0*i)+0.1;
                if(n==x)
                {
                    cout<<i<<endl;
                    break;
                }
            }
        }
        if(n<0)
        {
            n=-n;
            for(int i=31;i>=1;i-=2)
            {
                int t=pow(n*1.0,1.0/i)+0.1;
                int x=pow(t*1.0,1.0*i)+0.1;
                if(n==x)
                {
                    cout<<i<<endl;
                    break;
                }
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值