hdu4734数位dp

HDU4734


Description


For a decimal number x with n digits (A nA n-1A n-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2 n-2 + ... + A 2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).


Input


The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)


Output


For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.


Sample Input


3
0 100
1 10
5 100


Sample Output

Case #1: 1
Case #2: 2
Case #3: 13


题目大意


定义一个针对十进制数的函数F(x),对于十进制数(A nA n-1A n-2 ... A 2A 1),F(x) = A n * 2 n-1 + A n-1 * 2n-2 + ... + A2 * 2 + A1 * 1。现在给定A和B,求0-B之间F(x)<=F(A)的x有几个


#include <iostream>
#define LL long long int
#include <stdio.h>
#include <string.h>
using namespace std;
LL num[20];
LL dp[20][20005];/*dp[i][j]表示位置i能取0-9且当前和为j时有多少种
                   主要解决测试样例过多而超时的问题,用记忆化即可
                   解决样例中重复的情况*/
int changeToArray(LL decimal){
    int pos = 0;
    while(decimal){
        num[pos] = decimal%10;
        decimal = decimal/10;
        pos++;
    }
    return pos;
}
LL F(LL num[20],int len){
    LL ans = 0;
    LL pow2 = 1;
    for(int i = 0;i < len;i++){
        ans += pow2 * num[i];
        pow2 = pow2 * 2;
    }
    return ans;
}
//flag用于表示是否是临界下来的,比如1234有1、12、123这样临界的
int dfs(int pos,LL sum,bool flag){
    if(pos<0){
        return 0;
    }
    if(sum<0){
        return 0;
    }
    int ans = 0;
    int maxV = flag?num[pos]:9;//该位能取的最大值
    //for循环用于遍历当前位可取值
    if(!flag&&dp[pos][sum]>=0){
        return dp[pos][sum];
    }
    if(pos == 0){
        //取到最后一位的时候

        for(int i = 0;i <= maxV;i++){
            if(sum>=i){
                ans++;
            }
            else{
                break;
            }
        }
        return ans;
    }

    for(int i = 0;i <= maxV;i++){
        LL s = sum - i * (1<<pos);
        ans +=dfs(pos-1,s,flag&&i==maxV);
    }
    if(!flag){
        dp[pos][sum] = ans;
    }
    return ans;
}
int main()
{
    int T;
    LL A,B;
    cin>>T;
    memset(dp,-1,sizeof(dp));
    for(int i = 0;i < T;i++){
        scanf("%lld%lld",&A,&B);
        int aDigit = changeToArray(A);
        LL FA = F(num,aDigit);
        int bDigit = changeToArray(B);
        LL ans = dfs(bDigit-1,FA,true);
        printf("Case #%d: %lld\n",i+1,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值