HDU 4734 F(x) (数位DP)

For a decimal number x with n digits (A  nn-1n-2 ... A  21), we define its weight as F(x) = A  n * 2  n-1 + A  n-1 * 2  n-2 + ... + A  2 * 2 + A  1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
Input
The first line has a number T (T <= 10000) , indicating the number of test cases. 
For each test case, there are two numbers A and B (0 <= A,B < 10  9)
Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
Sample Input
3
0 100
1 10
5 100
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13

 【题解】

 大致题意:给一个区间,求这个区间内不大于F(x)并且不大于y的数的个数。

 首先得知道,这个F(x)公式算出来的值最大值不会超过5000,所以数组不用开太大。

 然后就是判断了,基本思路都是套模板,递归部分就是每次用上限减去组成的数,如果是正的就加1,否则继续找,  直到全部组合完了。


【AC代码】

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[12][5000];
int num[12];
int m,n;

int F(int x)//求上限
{
    int p=1;
    int ans=0;
    while(x)
    {
        ans+=(x%10)*p;
        x/=10;
        p<<=1;
    }
    return ans;
}

int dfs(int pos,int value,int limit)//value 为上限值减去上一位组成的数的余数
{
    if(value<0) return 0;//如果余数提前小于0了  直接退
    if(pos<0) return value>=0;//余数大于0  符合条件  返回1
    if(!limit && dp[pos][value]!=-1) return dp[pos][value];
    int ans=0;
    int endi= limit ? num[pos]:9;
    for(int i=0;i<=endi;++i)
    {
        ans+=dfs(pos-1,value-i*(1<<pos),limit&&i==endi);
    }
    if(!limit) dp[pos][value]=ans;
    return ans;
}

int solve(int x)
{
    int len=0;
    while(x)
    {
        num[len++]=x%10;
        x/=10;
    }
    return dfs(len-1,F(m),1);
}

int main()
{
    int t;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&t);
    for(int i=1;i<=t;++i)
    {
        scanf("%d%d",&m,&n);
        printf("Case #%d: %d\n",i,solve(n));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值