Eclipse导入已有的项目后项目报错的解决办法

如要转载,请附上本博客链接!

第一种:jsp报错

选择windows-->preference-->列表找到Validation-->点击Disable All ->> Apply ->> Apply and Close(ok了)

 

第二种:src代码报错---一般是源代码不兼容,例如源代码使用的jdk。。。

项目右击->>Build Path ->> Configure Build Path ->> Liberaries

->> 选中列表中的JRE System Library[jdk.....]  *(注意:这里的jdk一般就和本机上的就不一样了,所以要替换)

->>选择右边的Remove ->>再选择Add Library ->> 选择JRE System Library ->> Next ->> 选择你正在用的版本(一般选默认就行) ->> Finish  (OK了)

 

第三种:src下的servlet报错---一般是web的Tomcat在捣鬼

项目右击->>Build Path ->> Configure Build Path ->> Liberaries

->> 选中左边列表中的Apache Tomcat v.....(注意:治理就是要把项目中用的Tomcat改成你正在使用的Tomcat)

->>Remove  ->> Add Library ->>  选择Server Runtime ->> Next

->>  选择本机正在使用的Tomcat (注意:我这里说的是Tomcat,不是Tomcat版本,因为有可能你创建了很多个同一版本的Tomcat,但是只能选你正在用的那个,我是吃过这个亏了)

->> Finish ->>Apply ->>Apply Close   (OK了)

 

第四种:如果前三种都试过了项目名上面还有红叉,

项目右击->> Build Path ->>  Configure BuildPath ->> 左边选择 Targeted RunningTimes ->> 选择你正在使用的Tomcat ->> Apply and close    (OK了)

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页