Knight Moves(TUD Programming Contest 2001)

题目:http://poj.org/problem?id=1915

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
在这里插入图片描述

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output

5
28
0

可以单向搜索也可以双向搜索,,这里用的是双向广度搜索

AC代码:

#include <iostream>
#include <queue>
#include <string.h>
using namespace std;

struct Point{
	
	int x,y;
};

int n;
int vis[400][400],pre[400][400];
Point begin,end;

int x[8] = {-2,-2,-1,1,2,2,1,-1};
int y[8] = {-1,1,2,2,1,-1,-2,-2};

int bfs(){
	
	queue<Point> q;
	q.push(begin);
	q.push(end);
	
	vis[begin.x][begin.y] = 1;		//从起点来的标记1
	vis[end.x][end.y] = 2;			//从终点来的标记2
	
	Point cur,next;
	
	while(!q.empty()){
		
		cur = q.front();
		q.pop();
		
		for(int i = 0;i<8;i++){
			
			next.x = cur.x + x[i];
			next.y = cur.y + y[i];
			
			if(next.x < 0 || next.x >= n || next.y < 0 || next.y >= n) continue;
			
			if(!vis[next.x][next.y]){
				
				vis[next.x][next.y] = vis[cur.x][cur.y];
				pre[next.x][next.y] = pre[cur.x][cur.y] + 1;
				q.push(next);
			}
			
			if(vis[next.x][next.y]!=vis[cur.x][cur.y])	//如果有交集返回两部分的和+1,因为最后一步没有算。。
				return pre[next.x][next.y] + pre[cur.x][cur.y] + 1;
		}
		
	}
	
	return -1;
}

int main(){
	
	ios_base::sync_with_stdio(false);
	cin.tie(0);
	
	int t;cin >> t;
	
	while(t--){
		
		cin >> n;
		cin >> begin.x >> begin.y;
		cin >> end.x >> end.y;
		
		memset(vis,0,sizeof(vis));
		memset(pre,0,sizeof(pre));
		
		if(begin.x == end.x && begin.y == end.y)
			cout << 0 << endl;
		else
			cout << bfs() << endl;
	}
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值