Knight Moves(马的移动)

             A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

           Of course you know that it is vice versa. So you offer him to write a program that solves the ”difficult” part.

           Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

 

Input

         The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a..h) representing the column and a digit (1..8) representing the row on the chessboard.

Output

For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’. Sample Input

 Sample Input

e2   e4

a1   b2

b2   c3

a1   h8

a1   h7

h8   a1

b1  c3

f6   f6

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

 这一题本来也不难,一个广搜模板就搞定了,但是我的广搜不好,所以要多理解一下。

题意大概就是象棋里马的走法,走日的形状,

如图所示,在不超过边界的情况下,可以从中心走(1-8)任意一个点。

 整个方格为1-8,a-h。8*8的棋盘,

问从第一个坐标走到第二个坐标最小需要走多少步。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#include<iostream>
using namespace std;
#define inf 0x3f3f3f3f
int z,w;
int minn;
int book[10][10],vis[10][10];
int cmp[8][2]={{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1},{-1,2}};
struct point
{
    int x,y;
}tmp1,tmp2;

int main()
{
    queue<point>q;
    char b[4],c[4];
    while(scanf("%s%s",b,c)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        memset(book,0,sizeof(book));
        minn=inf;
        int xx,yy;
        xx=b[0]-'a';
        yy=b[1]-'1';
        z=c[0]-'a';
        w=c[1]-'1';
        //printf("x==%d\ty==%d\tz==%d\tw==%d\n",x,y,z,w);
       vis[xx][yy]=0;
       while(!q.empty())
       {
           q.pop();
       }
       tmp1.x=xx;
       tmp1.y=yy;
       vis[xx][yy]=1;
       q.push(tmp1);//将起点压入队列。
       int flag=0;
       while(!q.empty())
       {
           tmp1=q.front();//指向队首
           q.pop();//删除队首元素,防止后面的递归找错元素
           for(int i=0;i<8;i++)
           {
               tmp2.x=tmp1.x+cmp[i][0];
               tmp2.y=tmp1.y+cmp[i][1];
               if(tmp2.x<0||tmp2.y<0||tmp2.x>=8||tmp2.y>=8||book[tmp2.x][tmp2.y])
                continue;
                book[tmp2.x][tmp2.y]=1;
               vis[tmp2.x][tmp2.y]=vis[tmp1.x][tmp1.y]+1;
               q.push(tmp2);//将找到的点压入队列。
       }
       if(vis[z][w])
       {
           flag=1;
           break;
       }}
       if(flag)
        printf("To get from %s to %s takes %d knight moves.\n",b,c,vis[z][w]-1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值