joj2107

 

 

2107: Red and Black

ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K375207Standard

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


This problem is used for contest: 17  150 


Submit / Problem List / Status / Discuss


这个题是一个深度优先搜索的一个题,

从起始位置开始向四个方向进行搜索,

与其他深度优先搜索不同的是该题没有用到回溯。

只是 对于可以到达的地方进行标记即可。

#include<cstdio>

int row,col;
int sum;
char map[1000][24];
void find(int &u,int &v)
{
    for(int i=0;i<row;i++)
    {
        for(int j=0;j<col;j++)
        {
            if(map[i][j]=='@')
            {
                u=i,v=j;
                return ;
            }
        }
    }
}
void dfs(int u,int v)
{
    //向上
    if(u>0&&map[u-1][v]!='@'&&map[u-1][v]!='#')
    {
        map[u-1][v]='@';
        sum++;
        dfs(u-1,v);
    }
    //向下
    if(u<row-1&&map[u+1][v]!='@'&&map[u+1][v]!='#')
    {
        map[u+1][v]='@';
        sum++;
        dfs(u+1,v);
    }
    //向左
    if(v>0&&map[u][v-1]!='#'&&map[u][v-1]!='@')
    {
        map[u][v-1]='@';
        sum++;
        dfs(u,v-1);
    }
    //向右
    if(v<col-1&&map[u][v+1]!='@'&&map[u][v+1]!='#')
    {
        map[u][v+1]='@';
        sum++;
        dfs(u,v+1);
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    while(scanf("%d%d",&col,&row),col&&row)
    {
        getchar();
        for(int i=0;i<row;i++)gets(map[i]);
        int u,v;
        find(u,v);
        sum=1;
        dfs(u,v);
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值