joj1829

 1829: Candies


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s 8192K 922 220 Standard

All children like candies. One day a group of children are dividing M candies by the following rules.

1. The candies are numbered with 1,2,3…M.

2. One children can select a series of candies from small number to high number.

3. The candy chosen for the first time can be taken away.

4. From the second candy, it can be taken away iff its value is not more than the value of previous one.

Everyone wants to get candies as many as possible. Now assume you are the first child to choose candies, you are to write a program to calculate the largest number of candies you can take.

Input

There may be more than one test case in the input.

The first line of each case is an integer M(M<=1000), number of candies to be divided, followed by M lines indicating values of every candies. They are sorted by their numbers from 1 to M.

Output

For each case, print the answer.

Sample Input

5
5
2
4
1
3

Sample Output

3


This problem is used for contest: 148 


Submit / Problem List / Status / Discuss




#include<iostream>
#include<stdio.h>
using namespace std;
int sum[1000+10]={0};
int a[1000+10]={0};
int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)==1)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=1;
        }
        sum[0]=1;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<i;j++)
            {
                if(a[j]>=a[i]&&sum[i]<sum[j]+1)
                {
                    sum[i]=sum[j]+1;
                }
            }
        }
        int m=-1;
        for(int i=1;i<=n;i++)
        {
            if(m<sum[i])m=sum[i];
        }
        printf("%d\n",m);
    }
    return 0;
}



这个题目比较简单不说了。。。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值