joj1435

 1435: Goldbach


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s 8192K 787 206 Standard

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.


This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.


A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1p2) and (p2p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2 15. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0

Sample Output

1
2
1



This problem is used for contest: 81  118 




#include <iostream>
#include <string.h>
#include <math.h>
#define N 1<<15
using namespace std;
int prime[40000]={0};
int num[N/2+10]={0};
int main()
{
    int count=0;
    for(int i=2;i<=N;i++)
    {
        bool temp=true;
        for(int j=2;j<=sqrtl(i);j++)
        {
            if(i%j==0)
            {
                temp=false;break;
            }
        }
        if(temp)
        prime[count++]=i;
    }
    for(int i=0;i<count;i++)
    {
        for(int j=i;j<count;j++)
        {
            if(prime[i]+prime[j]<=(1<<15)&&(prime[i]+prime[j])%2==0)
            {
                num[(prime[i]+prime[j])/2]++;
            }
        }
    }
    int n;
    num[2]=1;
    while(cin>>n,n)
    {
        cout<<num[n/2]<<endl;
    }
    return 0;
}


Submit / Problem List / Status / Discuss


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值