Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

代码:

#include <stdio.h>
#include <string.h>
int i,j,n,m,t,x,y,q,p,startx,starty,flag;
int book[10][10];
char s[10][10];
void dfs(int x,int y,int step);

int main()
{
	
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{
		flag=0;
		memset(s,0,sizeof(s));
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++)
			scanf("%s",s[i]);
		if(n==0&&m==0&&t==0)
			break;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(s[i][j]=='S'){
					startx=i;starty=j;
				}
			}
		book[startx][starty]=1;
		dfs(startx,starty,0);		
		if(flag==1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

void dfs(int x,int y,int step)
{
	//printf("(%d,%d)--------%d\n",x,y,step);
	int tx,ty,k;
	int next[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
	if(flag==1)
		return ;
	if(s[x][y]=='D')
	{
		//printf("-------%d\n",step);
		if(step==t)
			flag=1;
		return ;
	}
	for(k=0;k<4;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<0||ty<0||tx>=n||ty>=m)
			continue;
		if((s[tx][ty]=='.'||s[tx][ty]=='D')&&book[tx][ty]==0)
		{
			book[tx][ty]=1;
			dfs(tx,ty,step+1);
			book[tx][ty]=0;
		}
	}
	return ;
}

ps:上面的代码写的时候不懂剪枝,再作一下补充。

先看代码:

#include <stdio.h>
#include <math.h>
#include <string.h>
int n,m,t,ex,ey,sx,sy,flag,dis,v;
int book[10][10];
char str[10][10];

void dfs(int x,int y,int step)
{
	//printf("(%d,%d)--------%d\n",x,y,step);
	int tx,ty,k;
	int next[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
	if(x==ex&&y==ey&&step==t)
		flag=1;
	if(flag==1||step>=t)
		return ;
	dis=abs(x-ex)+abs(y-ey);
	v=t-step-dis;
	//printf("dis---%d\nv---%d\n",dis,v);
	if(v<0||v%2!=0)
		return ;
	for(k=0;k<4;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<0||ty<0||tx>=n||ty>=m)
			continue ;
		if(str[tx][ty]!='X'&&book[tx][ty]==0)
		{
			book[tx][ty]=1;
			dfs(tx,ty,step+1);
			book[tx][ty]=0;
		}
	}
	return ;
}
int main()
{
	int p,i,j;
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{	
		flag=0;p=0;
		memset(str,0,sizeof(str));
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++)
			scanf("%s",str[i]);
		if(n==0&&m==0&&t==0)
			break;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(str[i][j]=='S'){
					sx=i;
					sy=j;
				}
				if(str[i][j]=='D'){
					ex=i;
					ey=j;
				}
				if(str[i][j]=='X')
					p++;		
			}
		//printf("S--(%d,%d),,,D--(%d,%d),,,X--%d\n",sx,sy,ex,ey,p);
		book[sx][sy]=1;
		if(n*m-p>=t)
	 		dfs(sx,sy,0);		
		if(flag==1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

本题中用到了一下剪枝:(本题是典型的奇偶剪枝)

1.如果当前时间即步数(step) >= T 而且还没有找到D点,则剪掉。

2.设当前位置(x, y)到D点(dx, dy)的最短距离为s,到达当前位置(x, y)已经花费时间(步数)step,那么,如果题目要求的时间T - step < s,则剪掉。

3. 对于当前位置(x, y),如果,(T-step-s)是奇数,则剪掉(奇偶剪枝)。

4.如果地图中,可走的点的数目(xnum) < 要求的时间T,则剪掉(路径剪枝)。

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值