Tempter of the bone

Tempter of the bone

时间限制: 1 Sec   内存限制: 32 MB
[ 提交][ 状态][ 讨论版]

题目描述

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed. 

输出

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

样例输入

3 3 7
.SD
...
...
3 3 8
.SD
...
...
3 4 7
.SD.
.X..
.X..
0 0 0

样例输出

YES
NO
NO
//该题目跟一般的搜索题目不同的是要定时到达,我用队列没做出来,就用了递归 
# include<stdio.h>
# include<string.h>
int b[4][2]={0,1,1,0,0,-1,-1,0};
int m,n,k,k1,n1,n2,step;
int v[10][10];
char a[10][10];
void dfs(int x,int y){
	if(a[x][y]=='D'&&step==k)
	{   k1=1;
		return ;
	}
	for(int i=0;i<4;i++)
	{
	int xx=x+b[i][0];
	int yy=y+b[i][1];
	if(xx>=0&&xx<n&&yy>=0&&yy<m&&a[xx][yy]!='X'&&v[xx][yy]==0)  //xx,yy在正确的范围 
	{
		step++;
		v[xx][yy]=1;  //标记 
		dfs(xx,yy);//回溯 
		v[xx][yy]=0;
		step--;
	}
	}
	return ;
}
int main(){
	while(~scanf("%d%d%d",&n,&m,&k)&&n&&m&&k)
	{
		getchar();
		int t=1;
		for(int i=0;i<n;i++)
		{
			scanf("%s",a[i]);
			for(int j=0;t&&j<m;j++)
			{
				if(a[i][j]=='S')    //确定起始位置
				{
					n1=i;
					n2=j;
				}
			}
		}
		step=0;
		k1=0;
		memset(v,0,sizeof(v));
		  dfs(n1,n2);
		if(!k1)
		printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值