poj-2488 A Knight's Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:

给出一个p行q列的国际棋盘,马可以从任意一个格子开始走,问马能否不重复的走完所有的棋盘。如果可以,输出按字典序排列最小的路径。打印路径时,列用大写字母表示(A表示第一列),行用阿拉伯数字表示(从1开始),先输出列,再输出行。

解题思路:

如果马可以不重复的走完所有的棋盘,那么它一定可以走到A1这个格子。所以我们只需从A1这个格子开始搜索,就能保证字典序是小的;除了这个条件,我们还要控制好马每次移动的方向,控制方向时保证字典序最小(即按照下图中格子的序号搜索)。控制好这两个条件,直接从A1开始深搜就行了。

 代码:

#include <stdio.h>
#include <string.h>
int book[10][10];
int map[100][2];
int p,q,flag;
int next[8][2]=
	{-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};

void dfs(int x,int y,int step)
{
	int tx,ty,k,i;
	map[step][0]=x;
	map[step][1]=y;
	//printf("step--%d\n",step);
	//printf("%d %d\n",map[step][0],map[step][1]);
	if(step==q*p)
	{
		for(i=1;i<=step;i++)
			printf("%c%d",map[i][1]-1+'A',map[i][0]);
		printf("\n");
		flag=1;
	} 
	if(flag==1)
		return ;		
	for(k=0;k<8;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<=0||ty<=0||tx>p||ty>q)
			continue;
		if(book[tx][ty]==0)
		{
			book[tx][ty]=1;
			dfs(tx,ty,step+1);
			book[tx][ty]=0;
		}
		/*if(tx>0&&ty>0&&tx<=p&&ty<=q&&book[tx][ty]==0) 
		{
			book[tx][ty]=1;
			dfs(tx,ty,step+1);
			book[tx][ty]=0;
		}*/
	}
	return ;
}

int main()
{
	int n,i,count=1;
	scanf("%d",&n);
	while(n--)
	{
		flag=0;
		scanf("%d%d",&p,&q);
		memset(map,0,sizeof(map));
		memset(book,0,sizeof(book));
		printf("Scenario #%d:\n",count++);
		book[1][1]=1;
		dfs(1,1,1);
		if(flag==0)
			printf("impossible\n");
        if(n!=0)
            printf("\n");	
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值