A Knight's Journey POJ - 2488

题目链接:点这里

Background

    The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
    around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

这里写图片描述

Problem

    Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

    The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
    If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:

一个骑士要走完棋盘上所有的点一次且仅一次,起点和终点不限,求走的顺序并输出对应的下标,而且尽可能的优先输出字典序最小的那个.

思路:

典型的搜索,只是每次搜索的顺序要使字典序最小的顺序来搜索,然后用数组记录路径就OK了.

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<iostream>
using namespace std;

int n,m;
int path[67];
char pat[67];
bool vis[65][65];
bool check;
int dx[]={-2,-2,-1,-1,+1,+1,2,2}; // 骑士走的位置按字典序最小的来排列
int dy[]={-1,1,-2,+2,-2,+2,-1,1};

void dfs(int x,int y,int k)
{
    if(k==m*n)
        check=true;
    if(check)
        return ;
    for(int i=0;i<8;++i){
        int sx=x+dx[i];
        int sy=y+dy[i];
        if(sx>0&&sy>0&&sx<=n&&sy<=m&&vis[sx][sy]==false){
            vis[sx][sy]=true;
            path[k+1]=sy;
            pat[k+1]='A'+sx-1;
            dfs(sx,sy,k+1);
            vis[sx][sy]=false;
            if(check)
                return ;
        }
    }
}

int main()
{
    int cas=0;
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        swap(n,m);
        memset(vis,false,sizeof(vis));
        check=false;
        for(int i=1;i<=n;++i){
        for(int j=1;j<=m;++j){
            path[1]=j;
            pat[1]='A'+i-1;
            vis[i][j]=true;
            dfs(i,j,1);//从某一点开始搜索
            vis[i][j]=false;
            if(check)//如果搜到就输出解
                break;
        }
        if(check)
            break;
        }
        cout<<"Scenario #"<<++cas<<':'<<endl;
        if(check)
        for(int i=1;i<=n*m;++i)
            cout<<pat[i]<<path[i];
        else cout<<"impossible";
        cout<<endl;
    if(t)
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值