hdu 5053 the Sum of Cube

**Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.

Sample Input
2
1 3
2 5

Sample Output
Case #1: 36
Case #2: 224
**
水题,没什么思路好说的。
翻译:t组样例,求出在a到b范围内所有数的立方和,按照题目格式输出
唯一坑的地方就是注意数据范围,记得用long long

#include<stdio.h>
#include<math.h>
#include<stdlib.h>

int main()
{
    int t,a,b,i,j;
    long long sum;
    scanf("%d",&t);
    for( i = 1; i <= t; i ++)
    {
        scanf("%d%d",&a,&b);
        sum = 0;
        for( j = a; j <= b; j ++)
        {

            sum += pow(j,3);
        }
        printf("Case #%d: %lld\n",i,sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值