hdu5914 Triangle 【贪心】

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1413    Accepted Submission(s): 840


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases. 

For each test case, there is only one line describing the given integer n ( 1n20 ).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
Case #1: 1 Case #2: 1 Case #3: 2  

题意:读入n,有n个长度为1,2,3...n的木棍,问最少拿走多少根木棍,使剩下的任意两根木棍无法构成三角形。

思路:只有剩余的数字是斐波那契数1,2,3,5,8...时,拿走的木棍数才最少,所以我们最需要用木棍总数减去此范围内斐波那契数的总数就是需要拿走的最少木棍数。这道题数据范围不大,所以我是直接循环判断,数据范围比较大的话可以考虑打表。

#include<stdio.h>
int main()
{
    int first,fi,next,t,n,ans,t2=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        ans = 2;
        first = 1;
        next = 2;
        while(first+next <= n)
        {
            fi = next + first;
            ans ++;
            first = next;
            next = fi;
        }
        printf("Case #%d: ",++t2);
        if(n==1||n==2||n==3)
            printf("0\n");
        else
            printf("%d\n",n-ans);
    }
    return 0;
}




#include<stdio.h>
int main()
{
    int first,fi,next,t,n,ans,t2=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        ans = 2;
        first = 1;
        next = 2;
        while(first+next <= n)
        {
            fi = next + first;
            ans ++;
            first = next;
            next = fi;
        }
        printf("Case #%d: ",++t2);
        if(n==1||n==2||n==3)
            printf("0\n");
        else
            printf("%d\n",n-ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值