【二分匹配入门专题1】G - Asteroids poj3041【最小顶点覆盖】

37 篇文章 0 订阅
20 篇文章 0 订阅
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2
题意:有一个n*n的矩阵,输入k行数,每行数是一个点的坐标,一次性可以去掉矩阵一行或者一列的~~那个单词没查,反正就是去掉这些坐标点,问你最少的操作次数
思路:就是一个最小顶点覆盖的模板题,和杭电的2119一样。

 

#include<stdio.h>
#include<string.h>
#define N 550

int n,k;
int book[N],e[N][N],match[N];

int dfs(int u)
{
    int i;
    for(i = 1; i <= n; i ++)
    {
        if(!book[i]&&e[u][i])
        {
            book[i] = 1;
            if(!match[i]||dfs(match[i]))
            {
                match[i] = u;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int t1,t2,sum,i,j;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        sum = 0;
        memset(e,0,sizeof(e));
        memset(match,0,sizeof(match));
        for(i = 1; i <= k; i ++)
        {
            scanf("%d%d",&t1,&t2);
            e[t1][t2] = 1;
        }
        for(i = 1; i <= n; i ++)
        {
            memset(book,0,sizeof(book));
            if(dfs(i))
                sum ++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值