【并查集入门专题1】E - The Suspects poj1611【并查集模板】

37 篇文章 0 订阅
9 篇文章 0 订阅
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
题意:输入n和m,接下来m行,每行输入一个整数k,再输入k个整数,输入0,0结束输入,只要和0直接或者间接相联系的数字都计入总数,输出总数,注意,下标是从0开始。
思路:统计的时候,统计每个数的根结点是否和0的根结点相同,满足条件累计加
#include<stdio.h>
#define N 30010

int f[N],x[N];

int find(int u)
{
    if(f[u] == u)
        return u;
    else
    {
        f[u] = find(f[u]);
        return f[u];
    }
}

void merge(int u,int v)
{
    int t1,t2;
    t1 = find(u);
    t2 = find(v);
        
    if(t1 != t2)
        f[t1] = t2;
    return;
}

int main()
{
    int n,m,u,v,count,i,t;
    while(scanf("%d%d",&n,&m),(n+m)!=0)
    {
        for(i = 0; i < n; i ++)
            f[i] = i;
        for(i = 0; i < m; i ++)
        {
            int k;
            scanf("%d",&k);
            for(int j = 0; j < k; j ++)
                scanf("%d",&x[j]);
            for(int j = 0; j < k-1;j ++)
                merge(x[j],x[j+1]);
        }
         count = 0 ;
        for(i = 0; i < n; i ++)
            if(find(i)==find(0))
                count ++;
        printf("%d\n",count);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值