【背包专题】D - Coins hdu 2844 【01背包+二进制优化】

72 篇文章 0 订阅
40 篇文章 0 订阅
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

InputThe input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.OutputFor each test case output the answer on a single line.Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意:问能够将输入的钱币组合为1~m之间的数的种类总数,比如样例2:m=5,钱币可以组合为:1,2,4,5.所以总的种类数为4.
思路:没有求最值,而是求可到达状态数。参考《背包九讲》里的第九讲。定义dp[i]表示是否可以从这些硬币中选取一些硬币,使得面值之和为i,dp[i]的取值为1表示可以,0表示不可以。
  状态转移方程为dp[i] = dp[i]||dp[i-value[i]]||...dp[i-num[i]*value[i]]
处理每种硬币时,每个状态要转移的次数和num[i]有关,num[i]较大时,时间复杂度比较高,我们可以采用二进制数的方法优化,1,2,4...2^n,只要是小于num[i]的数,我们都可以用这些数字组合而来,将每一组硬币
面值相加作为一个硬币来处理,就可以转为01背包的问题来求解。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 100010

int n,m;
int dp[N],w[10010],value[110],num[110];

int main()
{
    int i,j,ans,x;
    while(scanf("%d%d",&n,&m),n+m)
    {
        memset(dp,0,sizeof(dp));
        for(i = 1; i <= n; i ++)
            scanf("%d",&value[i]);//硬币价值 
        for(i = 1; i <= n; i ++)
            scanf("%d",&num[i]);//硬币数量 
        ans = 0;    
        for(i = 1; i <= n; i ++)
        {
            for(j = 1;num[i] > 0 ; j*=2)//二进制划分硬币数量 
            {
                x = min(j,num[i]);
                w[++ans] = x*value[i];
                num[i] -= x;
            }
        }
        dp[0] = 1;//初始状态为可到达状态 
        for(i = 1; i <= ans; i ++)
        {
            for(j = m; j >= w[i];j--)
            {
                if(dp[j-w[i]])//如果状态可以到达 
                    dp[j] = 1;
            }
        }
        ans = 0;
        for(i = 1; i <= m; i ++)
            if(dp[i])
                ++ans;
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值