poj 1573 Robot Motion 【模拟】【刷题计划】

Robot Motion
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 14641   Accepted: 7032

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)


题意:在r行c列的地图中,机器人从第一行的start列开始出发,N,S,W,E分别表示北南西东四个方向,问机器人走出地图需要多少步,如果走不出地图,输出走到形成环状的步数以及形成环状路线的总步数。

思路:模拟机器人行走的过程,我是用了一个数组str存图,一个数组map存步数,一开始地图上的步数都为0,当遇到步数不为0 的情况,说明形成了环状。

(题目上明明说最多10行,我数组开为20还是tle,一直没有找到问题,睡了一觉起来忽然觉得题目范围不靠谱,把数组开大以后,果然A了)

#include<stdio.h>
#include<string.h>
int main()
{
    char str[200][200];
    int map[200][200];
    int c,r,start,flag;
    int i,j;
    while(scanf("%d%d%d",&r,&c,&start),c!=0||r!=0||start!=0)
    {
        memset(str,0,sizeof(str));
        memset(map,0,sizeof(map));
        for(i = 1; i <= r; i ++)
            scanf("%s",str[i]+1);
        map[1][start] = 1;
        i = 1;
        j = start;
        flag = -2;
        while(1)
        {
            if(str[i][j] == 'N')
            {
                if(i-1 < 1)//走出地图,flag标记为-1 
                    flag = -1;
                else if(map[i-1][j] == 0)//步数为0,说明没有访问过该处 
                {
                    map[i-1][j] = map[i][j] + 1;//步数增加 
                    --i;//位置也要改变 
                }    
                else //以上条件都不满足,说明形成环状
                    flag = map[i-1][j];//记录环开始的地方的步数 
            }
            else if(str[i][j] == 'S')//同上 
            {
                if(i + 1 > r)
                    flag = -1;
                else if(map[i+1][j] == 0)
                {
                    map[i+1][j] = map[i][j] + 1;
                    ++i;
                }
                else 
                    flag = map[i+1][j];
            }
            else if(str[i][j] == 'W')//同上 
            {
                if(j-1 < 1)
                    flag = -1;
                else if(map[i][j-1] == 0) 
                {
                    map[i][j-1] = map[i][j] + 1;
                    j--;
                }
                else 
                    flag = map[i][j-1];
            }
            else if(str[i][j] == 'E')//同上 
            {
                
                if(j + 1 > c)
                    flag = -1;
                else if( map[i][j+1] == 0)
                {
                    map[i][j+1] = map[i][j] + 1;
                    ++j;
                }
                else
                    flag = map[i][j+1];
            }
            if(flag != -2)//如果不为初始值,说明已经走出地图或者形成环 
                break;
        }
        if(flag == -1)
            printf("%d step(s) to exit\n",map[i][j]);
        else  
            printf("%d step(s) before a loop of %d step(s)\n",flag-1,map[i][j]-flag+1);
    }
    return 0;
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值