poj 3624 Charm Bracelet 【01背包】+poj2524【并查集】

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23
题意:给定背包容量和每个物体的重量以及分数,求最大分数。

思路:01背包的简单应用

emmm 这道题恐怕要笑死我~~我读错了 读成多重背包的题 hahaha 样例都过不去啊

//简单01背包 
#include<stdio.h>
#include<iostream>
using namespace std;
#include<string.h>
#define N 13000
int dp[N],wei[N],num[N];

int main()
{
	int n,v;
	while(scanf("%d%d",&n,&v)!=EOF)
	{
		for(int i = 0; i < n; i ++)
			scanf("%d%d",&wei[i],&num[i]);
		memset(dp,0,sizeof(dp));
		for(int i = 0; i <= n;i ++)
		{
			for(int j = v; j >= wei[i]; j --)
			{
				dp[j] = max(dp[j],dp[j-wei[i]]+num[i]);
			}
		}
		printf("%d\n",dp[v]);
	}
	return 0;
}

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
题意:有n个学生,给定m对学生编号,每对学生宗教信仰相同,问,不同的宗教信仰最多有多少个?

思路:并查集简单应用

//简单并查集
#include<stdio.h>
#define N 50000
int f[N];

int Find(int x)
{
	int y;
	if(x == f[x])
		return x;
	else
	{
		y = Find(f[x]);
		f[x] = y;
		return f[x];
	}
}

void Union(int n,int m)
{
	int x = Find(n);
	int y = Find(m);
	if(x != y)
		f[x] = y;
	return;
}

int main()
{
	int num1,num2, n,i,m;
	int count,t=0;
	while(scanf("%d%d",&n,&m),n!=0||m!=0)
	{
		for(i = 1;i <= n; i ++)
			f[i] = i;
		for(i = 1; i <= m; i ++)
		{
			scanf("%d%d",&num1,&num2);
			Union(num1,num2);
		}
		count = 0;
		for(i = 1; i <= n; i ++)
			if(i == f[i])
				count ++;
		printf("Case %d: %d\n",++t,count);
				
	}
	return 0;
} 






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值