zoj1151 I - Word Reversal 【简单字符串处理】【第三周练习】【the first day】

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.


Output

For each test case, print the output on one line.


Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

题意:将每组字符串的单词一一翻转输出,t组样例,每组样例包括n行字符串,每组样例间有空行。

思路:确定每个单词在字符数组中的起始位置和终止位置,将该区间内的单词翻转后存入数组,具体细节见注释。

总结:老师应该是看我们被上次的练习打击的太惨了,所以这次放一道签到题在这里吧,细心一点应该可是实现1A,可是我就是那个不细心的人呐,好好读题行不行,每组样例之间的空行呢!!

#include<stdio.h>
#include<string.h>
#define N 1000
struct node{
	char str[N];
}sum[N+10];

void Reverse(int start,int end,int number)
{
	char s[N];
	int j = 0;
	for(int i = end; i >= start; i--)
		s[j++] = sum[number].str[i];
	s[j] = '\0';//将从start开始到end结束的字符段翻转 
	for(int i = start,k= 0; i <= end&&s[k]!='\0'; i ++,k++)
		sum[number].str[i] = s[k];//翻转后存入原字符组 
	return;
}

int main()
{
	int t,l,n,start,end,flag=0;
	scanf("%d",&t);
	while(t--)
	{
		if(flag)
			printf("\n");//认真读题!! 
		flag = 1;
		scanf("%d",&n);
		getchar();
		for(int i = 0; i < n; i ++)
			gets(sum[i].str);
		for(int i = 0; i < n; i ++)
		{
			start = end=0;
			while(sum[i].str[start]!='\0')
			{
				if(sum[i].str[end]==' '||sum[i].str[end] =='\0')//遇到空格或者终止符说明为一个单词 
				{
					Reverse(start,end-1,i);//翻转函数 
					if(end == '\0')
						break;//字符串结尾直接跳出循环 
					start = end+1;//跳过空格开始翻转下一个字符段 
				}
				end ++;
			}
		}
		for(int i = 0; i < n; i ++)
			puts(sum[i].str);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值