某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input 本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。 Output 对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2Sample Output
2 -1
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 2200;
int book[maxn],head[maxn],dis[maxn];
int cnt,ans,n,m;;
struct node{
int to,w,next;
}vis[maxn];
void Init(int x,int y,int w)
{
vis[cnt].to = y;
vis[cnt].w = w;
vis[cnt].next = head[x];
head[x] = cnt ++;
return;
}
void spfa(int start,int end)
{
int i,j,nowq,to;
queue<int>q;
for(i = 0; i < n; i ++)
dis[i] = inf;
dis[start] = 0;
q.push(start);
book[start] = 1;
while(!q.empty())
{
nowq = q.front() ;
q.pop();
book[nowq]= 0;
for(i = head[nowq]; i !=-1; i = vis[i].next)
{
to = vis[i].to;
if(dis[to] > dis[nowq] + vis[i].w)
{
dis[to] = dis[nowq] + vis[i].w ;
if(!book[to])
{
book[to] = 1;
q.push(to);
}
}
}
}
ans = dis[end];
return;
}
int main()
{
int i,j;
int x,y,w,start,end;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i = 0; i <= n;i ++)
dis[i] = inf;
memset(book,0,sizeof(book));
memset(head,-1,sizeof(head));
cnt = 0;
for(i = 0; i < m; i ++)
{
scanf("%d%d%d",&x,&y,&w);
Init(y,x,w);
Init(x,y,w);
}
scanf("%d%d",&start,&end);
spfa(start,end);
if(ans != inf)
printf("%d\n",ans);
else
printf("-1\n");
}
return 0;
}