HDU 5532 Almost Sorted Array (dp)

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2508    Accepted Submission(s): 619


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)


题意:这题题意应该比较清晰,就是问你给出队列是否可以取去一个数后变成非严格递增或非严格递减的序列,可以输出YES,不行输出NO。

解题思路:先假可以,那么该子序列的非严格单调上升长度为len1,非严格单调递减子序列长度为len2,满足max(len1,len2)>=n,所以只要求出这两个长度即可,然后加以判断。

<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int maxn=100005;
int a[maxn],b[maxn];
vector<int> v;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        v.clear();
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        vector<int>::iterator it=v.begin();
        for(int i=0;i<n;i++)
        {
            if((it=upper_bound(v.begin(),v.end(),a[i]))==v.end())
                 v.push_back(a[i]);
            else
                *it=a[i];
        }
        int ans=v.size();
        v.clear();
        for(int i=n-1;i>=0;i--)
        {
            if((it=upper_bound(v.begin(),v.end(),a[i]))==v.end())
                v.push_back(a[i]);
            else
                *it=a[i];
        }
        int ans1=v.size();
        if(ans>=n-1 || ans1>=n-1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值