HDU-5532 Almost Sorted Array(LIS)

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3883    Accepted Submission(s): 984


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array   a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer   T  indicating the total number of test cases. Each test case starts with an integer   n  in one line, then one line with   n  integers   a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with   n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 

Source


题意:给你一段序列,让你判断其是否是 almost sorted ,如果是的话就输出YES,else NO

思路:看看其LIS长度是不是大于等于n-1,要二分,不然会TLE
ps:原来我以前upper_bound写不对是因为里面的地址放错了,sad

/*
题意
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int N = 100005;
int a[N],dp[N];
int main()
{
    int t,n;
    cin >> t;
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 1;i <= n;i++)
            scanf("%d",&a[i]);//,dp[i] = 1;
        int num = 1,pos;dp[1] = a[1];
        for(int i = 2;i <= n;i++)
            if(a[i] >= dp[num])
                dp[++num] = a[i];
            else
            {
                pos = upper_bound(dp+1,dp+num,a[i])-dp;
                dp[pos] = a[i];
            }

        int len = 1;dp[1] = a[n];
        for(int i = n-1;i >= 1;i--)
            if(a[i] >= dp[len])
                dp[++len] = a[i];
            else
            {
                pos = upper_bound(dp+1,dp+len,a[i])-dp;
                dp[pos] = a[i];
            }

        if(num >= n-1 || len >= n-1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值