HDU 4451 Dressing(计数)

Dressing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3807    Accepted Submission(s): 1722


Problem Description
Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing.
One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs.
Please calculate the number of different combinations of dressing under mom’s restriction.
 

Input
There are multiple test cases.
For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes.
Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious.
Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”.
The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K).
Input ends with “0 0 0”.
It is guaranteed that all the pairs are different.
 

Output
For each case, output the answer in one line.
 

Sample Input
  
  
2 2 2 0 2 2 2 1 clothes 1 pants 1 2 2 2 2 clothes 1 pants 1 pants 1 shoes 1 0 0 0
 

Sample Output
  
  
8 6 5 题意:衣服裤子鞋子分别有n,m,k件,指定某件衣服跟裤子不能搭配,或者某件裤子跟某双鞋子不能搭配,这个的指定有P条,问你有几种不同的搭配方式。 解题思路:用两个数组 c[maxn] 和 s[maxn] 分别表示第 i 条裤子与多少件衣服不可搭配和多少条裤子与多少双鞋子不可搭配(就是以裤子为中间媒介)。最后只要遍历 一遍所有的裤子,(n-c[i])*(k-s[i])就是每条裤子在满足条件的情况下有多少种搭配方式,最后将所有的搭配求和为ans即可。
<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn=1005;
bool vis1[maxn][maxn],vis2[maxn][maxn];
int c[maxn],s[maxn];
int main()
{
    int n,m,k,p,a,b;
    char str1[10],str2[10];
    while(~scanf("%d %d %d",&n,&m,&k) && n+m+k)
    {
        memset(vis1,false,sizeof(vis1));
        memset(vis2,false,sizeof(vis2));
        memset(c,0,sizeof(c));
        memset(s,0,sizeof(s));
        scanf("%d",&p);
        for(int i=0;i<p;i++){
            scanf("%s %d %s %d",&str1,&a,&str2,&b);
            if(str1[0]=='c' && str2[0]=='p')
            {
                if(!vis1[a][b]){
                    vis1[a][b]=true;
                    c[b]++;
                }
            }
            else{
                if(!vis2[a][b]){
                    vis2[a][b]=true;
                    s[a]++;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=m;i++)
            ans+=(n-c[i])*(k-s[i]);
        printf("%d\n",ans);
    }
    return 0;
}
</span>

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值