HDU 1003 Max Sum(最长连续子串和)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 175786    Accepted Submission(s): 40946


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6 ac代码:
#include<stdio.h>
#include<string.h>
int num[100005];
int main()
{
	int n,m;
	int q=1,i,j;
	scanf("%d",&n);
	while(n--)
	{
		int sum,b,e;//开始.结束和子串和
		int max;
		int k=1;
		int bz=0;//全部都是负数的时候标记为0
		scanf("%d",&m);
		for(i=1;i<=m;i++)
		scanf("%d",&num[i]);
		sum=b=e=max=0;
		for(j=1;j<=m;j++)
		{
			if(num[j]>0)//存在大于0的数,修改标记
			bz=1;
			sum+=num[j];
			if(sum<0)
			{
				sum=0;
				k=j+1;
			}
			if(sum>max)
			{
				max=sum;//修改变量
				b=k;
				e=j;
			}
		}
		if(bz==0)//全部为负数,所以怎么加都是变小,只有求最大的那一个负数
		{
			max=num[1];
			b=e=1;
			for(j=2;j<=m;j++)
			if(num[j]>max)
			{
				max=num[j];//找到修改起点和终点
				b=j;
				e=j;
			}
		}
		printf("Case %d:\n",q++);
		printf("%d %d %d\n",max,b,e);
		if(n>=1)
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值