POJ Network(最小生成树--kruskul)

Network
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14951 Accepted: 5868 Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4


题意:
是让连接所有节点,中间要记录路径的连接点,所以用kruskul,第一行输出最长的
权值,第二行输出有几条边。

这道题我也是醉了,测试样例是是错误的,刚开始我以为样例没错,最后发现输出
结果和样例不一样,但是想法没有错,就试着交了一发,没想到A了,= =!真正样
例应该是:
1
3
1 2
1 3
3 4
 

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 1001000
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
using namespace std;
int M,ss;
int pri[MAXN];
struct s
{
	int a;
	int b;
	int cost;
}dis[MAXN],q[MAXN];
bool cmp(s aa,s bb)
{
	return aa.cost<bb.cost;
}
int find(int x)
{
	int r=x;
	while(r!=pri[r])
	r=pri[r];
	int i=x,j;
	while(i!=r)
	{
		j=pri[i];
		pri[i]=r;
		i=j;
	}
	return r;
}
void connect(int xx,int yy,int num)
{
	int nx=find(xx);
	int ny=find(yy);
	if(nx!=ny)
	{
		pri[nx]=pri[ny];
		q[ss].a=xx;
		q[ss].b=yy;
		ss++;
		if(num>M)
		M=num;
	}
}
int main()
{
	int i,n,m,d,e,f;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		M=0;
		ss=0;
		for(i=1;i<=n;i++)
		pri[i]=i;
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&d,&e,&f);
			dis[i].a=d;
			dis[i].b=e;
			dis[i].cost=f;
		}
		sort(dis,dis+m,cmp);
		for(i=0;i<m;i++)
		{
			connect(dis[i].a,dis[i].b,dis[i].cost);
		}
		printf("%d\n%d\n",M,ss);
		for(i=0;i<ss;i++)
		printf("%d %d\n",q[i].a,q[i].b);
    }
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值