HDOJ 2795 Billboard(单点更新+区间最值)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15661    Accepted Submission(s): 6599


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1 题意:一个广告牌,高为h,宽为w,在上面放广告,尽量放在最上层,最左边,求的能放的最好的位置是多少。 思路:将广告牌的层数作为线段树的区间,然后把每一层的宽度作为节点变量,当放置的时候,从头开始遍历, 直到找到能放置的点,区间的最值表示这个区间内能放置的最长的广告,这样可省时。 ac代码:
#include<stdio.h>
#include<string.h>
struct s
{
	int left;
	int right;
	int weight;
}tree[10000000];//刚开始一直re,直到我定义到了1000w(衰
int h,w,num;
int max(int a,int b)
{
	return a>b?a:b;
}
void build(int l,int r,int i)
{
	tree[i].left=l;
	tree[i].right=r;
	if(l==r)
	{
		tree[i].weight=w;
		return;
	}
	int mid;
	mid=(l+r)/2;
	build(l,mid,i*2);
	build(mid+1,r,i*2+1);
	tree[i].weight=max(tree[i*2].weight,tree[i*2+1].weight);//区间最值
}
void update(int i,int cost)
{
	if(tree[i].left==tree[i].right)
	{
		if(tree[i].weight>=cost)
		tree[i].weight-=cost;
		num=tree[i].left;//如果能放,记录节点值
		return;
	}
	if(cost<=tree[i*2].weight)
	update(i*2,cost);
	else
	update(i*2+1,cost);
	tree[i].weight=max(tree[i*2].weight,tree[i*2+1].weight);//更新最值
}
int main()
{
	int i,n,a;
	while(scanf("%d%d%d",&h,&w,&n)!=EOF)
	{
		if(h>n)
		h=n;
		build(1,h,1);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			if(tree[1].weight<a)
			{
				printf("-1\n");
				continue;
			}
			num=-1;
			update(1,a);
			printf("%d\n",num);
		}
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值