HDOJ 5417 Victor and Machine(模拟)

Victor and Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 577    Accepted Submission(s): 333


Problem Description
Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every w seconds. However, the machine has some flaws, every time after x seconds of process the machine has to turn off for y seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.

Now, at the 0 second, the machine opens for the first time. Victor wants to know when the n -th ball will be popped out. Could you tell him?
 

Input
The input contains several test cases, at most 100 cases.

Each line has four integers x , y , w and n . Their meanings are shown above。

1x,y,w,n100 .
 

Output
For each test case, you should output a line contains a number indicates the time when the n -th ball will be popped out.
 

Sample Input
  
  
2 3 3 3 98 76 54 32 10 9 8 100
 

Sample Output
  
  
10 2664 939
 

Source
BestCoder Round #52 (div.2)


大意:一个机器,每运行x秒就要停止y秒,每运行w秒会吐出一个球,求第n个吐出来时使用了多少时间。

思路:各种少看条件,就把题想麻烦了,注意:
1.每次开启都会吐出一个球,这个刚开始没看到,发现样例都没法算。
2.运行的时间不能累加,就是x<w时,x不能算进运行时间,例如:x=2,w=3,那么运行的时候是不可能吐球的,
只能靠开启机器来吐球。那么这样就很简单了,刚开始我想复杂了,以为可以累加运行时间,哎...


ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 2555
#define INF 0xfffffff
#define MIN(a,b) a>b?b:a
using namespace std;
int main()
{
	int x,y,w,n;
	while(scanf("%d%d%d%d",&x,&y,&w,&n)!=EOF)
	{
		int num=0;
		int sum=0; 
		int ans=0;
		if(x<w)
		{
			printf("%d\n",(x+y)*(n-1));
			continue;
		}
		int s=x/w;
		while(1) 
		{
			num++;
			if(num==n)
			break;
			if(num+s>=n)
			ans=ans+w*(n-num),num=n;
			else
			ans=ans+x+y,num+=s;
			if(num==n)
			break;
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值