HDOJ 5546 Ancient Go (DFS)

Ancient Go

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 49    Accepted Submission(s): 25


Problem Description
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.
 

Input
The first line of the input gives the number of test cases, T(1T100) . T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.
 

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.
 

Sample Input
  
  
2 .......xo ......... ......... ..x...... .xox....x .o.o...xo ..o...... .....xxxo ....xooo. ......ox. .......o. ...o..... ..o.o.... ...o..... ......... .......o. ...x..... ........o
 

Sample Output
 
 
Case #1: Can kill in one move!!! Case #2: Can not kill in one move!!!
Hint
In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component. In the second test case, there is no way to kill Su Lu's component. 题意:一个9*9的棋盘,判断能否把接下来的一个x,放到地图中的一个空白位置上。 使得出现一个联通块内的o,找不到任何一个可以扩展的联通块位置'.' 思路:枚举o周围的x放置,如果周围可放置数为1,表示成功,注意重复记录,所以用两个数组个标记 ac代码:  
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 100100
#define MOD 1000000007
#define LL long long
#define INF 0xfffffff
using namespace std;
char map[10][10];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int v[10][10];
int v1[10][10];
int cnt;
int check(int x,int y)
{
	if(x<0||x>=9||y<0||y>=9)
	return 1;
	return 0;
}
void dfs(int x,int y)
{
	for(int i=0;i<4;i++)
	{
		int nx=x+dir[i][0];
		int ny=y+dir[i][1];
		if(check(nx,ny)==0&&map[nx][ny]=='.'&&!v1[nx][ny])
		{
			v1[nx][ny]=1;
			cnt++;
		}
	}
	for(int i=0;i<4;i++)
	{
		int nx=x+dir[i][0];
		int ny=y+dir[i][1];
		if(check(nx,ny)==0&&map[nx][ny]=='o'&&!v[nx][ny])
		{
			v[nx][ny]=1;
			dfs(nx,ny);
		}
	}
}
int main()
{
    int t,n,i,j;
    int cas=0;
    scanf("%d",&t);
    while(t--)
    {
    	for(i=0;i<9;i++)
    	scanf("%s",map[i]);
    	int bz=0;
		memset(v,0,sizeof(v));
    	for(i=0;i<9;i++)
    	{
    		for(j=0;j<9;j++)
    		{
    			if(map[i][j]=='o'&&!v[i][j])
    			{
    				memset(v1,0,sizeof(v1));
    				cnt=0;
    				v[i][j]=1;
    				dfs(i,j);
    				if(cnt==1)
    				{
    					bz=1;
    					break;
					}
			    }
			}
			if(bz)
			break;
		}
		if(bz)
		printf("Case #%d: Can kill in one move!!!\n",++cas);
		else
		printf("Case #%d: Can not kill in one move!!!\n",++cas);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值