HDOJ 1787 GCD Again (欧拉函数)

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2713    Accepted Submission(s): 1141


Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
 

Sample Input
  
  
2 4 0
 

Sample Output
  
  
0 1 题意:求小于n的数k且gcd(n,k)>1的个数 思路:求出gcd(k,n)==1的个数,即欧拉函数值,除去自身,那么就是用n-1减去求出的结果 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 100100
#define MOD 1000000007
#define LL long long
#define INF 0xfffffff
using namespace std;
LL eular(LL n)
{  
    LL i,res=n;  
    for(i=2;i*i<=n;i++)  
        if(n%i==0)
		{  
            res=res/i*(i-1);  
            while(n%i==0)
			n/=i;  
        }  
    if(n>1) 
	res=res/n*(n-1);  
    return res;  
}
int main()
{
    LL n;
	while(scanf("%lld",&n)!=EOF,n)
	{
		LL ans=eular(n);
		printf("%lld\n",n-ans-1);
	} 
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值