NYOJ 1132 promise me a medal (判断两线段是否相交)

promise me a medal

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述

  you all know that creat2012 will go to a regional. and i want you all pray for us. thx.

  for this problem, you need judge if two segments is intersection(相交的). if intersect(相交), print yes and the point. else print no.

  easy ? ac it.

输入
T <= 100 cases
8 real numbers (double)
promise two segments is no coincidence.
输出
no
or yes and two real number (one decimal)
样例输入
2
0 0 2 2 1 0 3 2
0 0 2 2 0 2 2 0
样例输出
no
yes 1.0 1.0


坑点在于首尾相连这一情况

思路:先判断线段是否相交,然后在求交点

ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 201000
#define MAX(a,b) a>b?a:b
#define fab(a) ((a)>0?(a):-(a))
using namespace std;
struct s
{
	double x;
	double y;
}fb,fe,sb,se,r;
double a,b,c,a1,b1,c1,a2,b2,c2;
void fun(s p,s q)
{
    a=q.y-p.y;
    b=p.x-q.x;
    c=q.x*p.y-p.x*q.y;
}
int find(s p1,s p2,s q1,s q2)
{
    double m,n;
    fun(p2,q2);
    a2=a,b2=b,c2=-c;
    m=a*p1.x+b*p1.y+c;
    n=a*q1.x+b*q1.y+c;
    if(m*n>0)
	return 0;
    if(fab(m)<1e-8&&fab(n)<1e-8)
    {
        if(fab(b)<1e-8)
        {
            if(((p1.y<min(p2.y,q2.y)&&q1.y<min(p2.y,q2.y))||(p1.y>max(p2.y,q2.y)&&q1.y>max(p2.y,q2.y))))
			return 0;
            else
            {
                if(p1.y==p2.y||p1.y==q2.y)
				r.x=p1.x,r.y=p1.y;
                else
				r.x=q1.x,r.y=q1.y;
                return 1;
            }
        }
        if(((p1.x<min(p2.x,q2.x)&&q1.x<min(p2.x,q2.x))||(p1.x>max(p2.x,q2.x)&&q1.x>max(p2.x,q2.x))))
		return 0;
        else
        {
            if(p1.x==p2.x||p1.x==q2.x)
			r.x=p1.x,r.y=p1.y;
            else
			r.x=q1.x,r.y=q1.y;
            return 1;
        }
    }
    fun(p1,q1);
    a1=a,b1=b,c1=-c;
    m=a*p2.x+b*p2.y+c;
    n=a*q2.x+b*q2.y+c;
    if(m*n>0)
	return 0;
    r.x=(c1*b2-c2*b1)/(a1*b2-a2*b1);
    r.y=(a1*c2-a2*c1)/(a1*b2-a2*b1);
    return 1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&fb.x,&fb.y,&fe.x,&fe.y,&sb.x,&sb.y,&se.x,&se.y);
		if(find(fb,sb,fe,se))
		printf("yes %.1lf %.1lf\n",r.x,r.y);
		else
		printf("no\n");
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值