HDOJ 1025 Constructing Roads In JGShining's Kingdom (LIS nlogn)

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20601    Accepted Submission(s): 5814


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
  
  
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
 
 
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended. 题意:有n个富饶的城市和n个贫穷的城市,然后每个富饶的城市有一种多余的资源,没有两个城市多余的资源一样, 每个贫穷的城市缺少一种资源,没有两个城市缺少的资源一样,要在他们之间建路,中间不能相交,问最多建几条路 ,当两个城市缺少的和多余的刚好匹配时,就表示能建路,但是建不建不一定 思路:这题题面太长了,盯着翻译看了好久啊,因为n个城市,没有城市缺少的东西一样,所说一个数组存储i号城市 缺少的东西需要在num[i]号城市获得,然后就转换成了最长非递减序列的问题 WA的地方:1.刚开始没想到非递减这个问题,只想到递增,提供一组数据 5 2 2 3 3 4 1 1 4 5 5 答案是3 2.最后的输出road和roads没看到,注意最后有两个换行 ac代码:  
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
int dp[MAXN];
int num[MAXN];
int main()
{
	int t,n;
	int i,p,r;
	int cas=0;
	while(scanf("%d",&n)!=EOF)
	{
		mem(num);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&p,&r);
			num[p]=r;
		}
		dp[0]=-1;
		int len=0;
		for(i=1;i<=n;i++)
		{
			if(num[i]==0)
			continue;
			if(num[i]>=dp[len])
			{
				dp[++len]=num[i];
				continue;
		    }
			int low=0,high=len;
			int mid=(low+high+1)/2;
			while(mid<high)
			{
				if(num[i]<dp[mid])
				high=mid;
				else
				low=mid;
				mid=(low+high+1)/2;
			}
			dp[mid]=num[i];
		}
		printf("Case %d:\n",++cas);
		if(len==1)
		printf("My king, at most %d road can be built.\n\n",len);
		else
		printf("My king, at most %d roads can be built.\n\n",len);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值