PAT 1090 Highest Price in Supply Chain 超时修正

1090 Highest Price in Supply Chain 分数 25

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si​ is the index of the supplier for the i-th member. Sroot​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目描述:

        求树的深度且深度最大的叶子节点个数。该题可以先用邻接表表示该树,再通过bfs过程中记录其深度和该深度的结点数解决。采用python实现该过程,后发现有46测试点超时。

超时代码:

_, p, r = list(map(float, input().split()))

lines = list(map(int, input().split()))
tree = {}
for i, li in enumerate(lines):
    tree[li] = tree.get(li, []) + [i]

layer, c = -1, 0
res = [-1]
while res:
    c = len(res)
    for i  in range(c):
        ri = res.pop(0)
        res.extend(tree.get(ri, []))
    layer+=1
d ="%.2f" %(p*(1.0+r/100)**(layer-1))
print( d +" "+str(c))

首先发现代码中一读数据是存在数组拼接后赋值给新数组的情况,可以改进为在原数组上进行append操作。其次在bfs过程中每层都需依次pop数据,若同时把这些数据pop出去速度会更快,这里可采用两个数组实现,一个表示当前层的结点,一个表示下一层的结点,遍历当前层结点,生成下一层的结点,遍历结束后,将下一层结点赋给当前层,这样之前的当前层所有结点都被删除,不用一个一个地pop。

AC代码:

_, p, r = list(map(float, input().split()))

lines = list(map(int, input().split()))
tree = {}
for i, li in enumerate(lines):
    
    if tree.get(li):
        tree[li].append(i)  # 用append 代替 数组`add` 
    else:
        tree[li] =[i]

layer, c = -1, 0
pre, now = [-1], []  
while pre:
    now, c = [], len(pre)
    for i  in pre:
        now.extend(tree.get(i, []))
    pre = now  # 用赋值代替多个pop
    layer+=1
d ="%.2f" %(p*(1.0+r/100)**(layer-1))
print( d +" "+str(c))

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值