HDU - 1115 Lifting the Stone

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9539    Accepted Submission(s): 4004

Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 

Sample Input

2 4 5 0 0 5 -5 0 0 -5 4 1 1 11 1 11 11 1 11

Sample Output

0.00 0.00 6.00 6.00

Source

Central Europe 1999

Recommend

这是求多边形重心问题:

n剖分成N-2个三角形,分别求出其重心和面积,这时可以想象,原来质量均匀分布在内部区域上,而现在质量仅仅分布在这N-2个重心点上(等假变换),这时候就可以利用刚才的质点系重心公式了。

+

不过,要稍微改一改,改成加权平均数,因为质量不是均匀分布的,每个质点代表其所在三角形,其质量就是该三角形的面积(有向面积!),——这就是权

①质量集中在顶点上。n个顶点坐标为(xi,yi),质量为mi,则重心

 X = ∑( xi×mi ) / ∑mi / 3

 Y = ∑( yi×mi ) / ∑mi / 3

②质量分布均匀。这个题就是这一类型,算法和上面的不同。

  特殊地,质量均匀的三角形重心:

  X = ( x0 + x1 + x2 ) / 3  

  Y = ( y0 + y1 + y2 ) / 3

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int cas , n ;
struct centre
{
       double x , y ;
}p0 , p1 , p2 ;
double Area( centre p0 , centre p1 , centre p2 )
{
       double area = 0 ;
       double x1=p1.x-p0.x;
       double y1=p1.y-p0.y;
       double x2=p2.x-p0.x;
       double y2=p2.y-p0.y;
       area =x1*y2-y1*x2;
       return area / 2 ; 
 // 另外在求解的过程中,不需要考虑点的输入顺序是顺时针还是逆时针,相除后就抵消了。
}
int main ()
{   
    double sum_x , sum_y , sum_area , area;
    scanf ( "%d" , &cas ) ;
    while ( cas -- )
    {    sum_x = sum_y = sum_area = 0 ;
          scanf ( "%d" , &n ) ;
          scanf ( "%lf%lf" , &p0.x , &p0.y ) ;
          scanf ( "%lf%lf" , &p1.x , &p1.y ) ;
          for ( int i = 2 ; i < n ; ++ i )
          {  scanf ( "%lf%lf" , &p2.x , &p2.y ) ;
              area = Area(p0,p1,p2) ;
              sum_area += area ;
              sum_x += (p0.x + p1.x + p2.x) * area ;
              sum_y += (p0.y + p1.y + p2.y) * area ;
              p1 = p2 ;
          }
          printf ( "%.2lf %.2lf\n" , sum_x / sum_area / 3 , sum_y / sum_area / 3 ) ;
    }
    return 0 ;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值