Farey Sequence

22 篇文章 0 订阅
3 篇文章 0 订阅

http://poj.org/problem?id=2478 

求欧拉值的前n项和

 

 

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<map>
#define ll long long
using namespace std;
ll a[1000005];
void phi() {
      a[0] = 0;
      a[1] = 0;
      for (int i = 2; i < 1000005; i ++)
            a[i] = i;
      for (int i = 2; i < 1000005; i ++) {
            if(a[i] == i) {
                  for (int j = i; j < 1000005; j += i)
                        a[j] = a[j] - a[j] / i;
            }
      }
      // for (int i = 2; i < 100; i ++)
      //       printf("%lld\n", a[i]);
}
int main()
{
     int  t;
     a[1]=0;
     a[2]=1;
     a[3]=3;
     a[4]=5;
     phi();
     for (int i = 2; i < 1000005; i ++) {
           a[i] += a[i - 1];
     }
     while (cin>>t,t)  {
           printf("%lld\n", a[t]);
     }

    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值