Farey Sequence(欧拉函数板子题)

题目链接:http://poj.org/problem?id=2478

Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19736 Accepted: 7962

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

POJ Contest,Author:Mathematica@ZSU
 
题目大意:很容易可以发现是求2-n的所有数的欧拉函数值之和
看代码:
/**
有三条特性
若a为质数  phi[a]=a-1
若a为质数,b%a==0   phi[a*b]=phi[b]*a;
若a b 互质  phi[a*b]=phi[a]*phi[b](当a为质数  如果b%a!=0)

*/
#include<iostream>
#include<cstdio>
using namespace std;
typedef long long LL;
const int maxn=1e6+50;
int phi[maxn],prime[maxn],p[maxn];//phi[i]代表i的欧拉函数值  prime[i]=0代表是素数 1代表不是素数   p存储素数
void make()
{
    phi[1]=1;//特例
    int num=0;
    for(int i=2;i<=maxn;i++)
    {
        if(!prime[i])//是素数
        {
            p[num++]=i;//
            phi[i]=i-1;//素数的欧拉函数值就是它的值减1
        }
        for(int j=0;j<num&&p[j]*i<maxn;j++)//用当前已经得到的素数筛去p[j]*i
        {
            prime[p[j]*i]=1;//可以确定p[j]*i不是质数
            if(i%p[j]==0)//第二条特性
            {
                phi[p[j]*i]=phi[i]*p[j];
                break;//欧拉筛的核心语句  保证每个数只会被自己最小的质因子筛掉一次
            }
            else phi[p[j]*i]=phi[i]*phi[p[j]];
        }
    }
    return ;
}

int main()
{
    make();
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        LL sum=0;
        for(int i=2;i<=n;i++) sum+=phi[i];
        printf("%lld\n",sum);
    }
//    for(int i=1;i<=100;i++) cout<<phi[i]<<" ";

    return 0;
}

 

转载于:https://www.cnblogs.com/caijiaming/p/10638640.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值