Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.
Note:
You can assume that two segments would not intersect at more than one point.
Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each case, print the number of intersections, and one line one case.
Sample Input
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
Sample Output
1 3
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<map>
#define ll long long
using namespace std;
struct node
{
double sx,sy;
double mx,my;
double x,y;
}a[105];
bool juge(node x,node y)
{
double k1=(x.sx-y.sx)*(y.my-y.sy)-(y.mx-y.sx)*(x.sy-y.sy);
double k2=(y.mx-y.sx)*(x.my-y.sy)-(x.mx-y.sx)*(y.my-y.sy);
if(k1*k2>=0)
return 1;
return 0;
}
int main()
{
///求线段总共有多少个交点
int n;
std::ios::sync_with_stdio(false);
while (cin>>n,n) {
long long w=0;
if(n==1)
{
cout<<"0"<<endl;
break;
}
for(int i=1;i<=n;i++)
{
cin>>a[i].sx>>a[i].sy>>a[i].mx>>a[i].my;
}
for(int i=1;i<n;i++)
{
for(int j=i+1;j<=n;j++)
{
//if(juge(a[i],a[j])==false) cout<<i<<j;
w+=juge(a[i],a[j])&&juge(a[j],a[i]);
}
}
cout<<w<<endl;
}
return 0;
}