hdu-1711 kmp 附板子 ʕ •ᴥ•ʔ

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

 

Sample Input

 

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

 

 

Sample Output

   6

   -1

题意: 给你一个长度为n的字串 一个长度为m的模板串

 

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#define ll long long
using namespace std;
int a[1000010],b[1000010];
int nexxt[1000010];
int n,m;
void getnext()
{
	int j=-1,i=0;
	nexxt[0]=-1;
	while(i<m)
	{
		if(j==-1||b[i]==b[j])
		{   
			i++;
			j++;
			nexxt[i]=j;
		}
		else
		j=nexxt[j];
	}
	
}
int kmp()
{
	getnext();
	int j=0,i=0;
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		i++,j++;
		else
		{
			j=nexxt[j];
		}		
		if(j==m)
		{
			return i-m+1;
		}
	}
	return -1;
	
}
int main()
{
	ios::sync_with_stdio(false);
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		for(int i=0;i<n;i++)
		cin>>a[i];
		for(int i=0;i<m;i++)
		{
			cin>>b[i];
		}
		cout<<kmp()<<endl;
	}
	return 0;
} 

模板:

 

void getnext()
{
	int j=-1,i=0;
	nexxt[0]=-1;
	while(i<m)
	{
		if(j==-1||b[i]==b[j])
		{   
			i++;
			j++;
			nexxt[i]=j;
		}
		else
		j=nexxt[j];
	}
	
}
int kmp()
{
	getnext();
	int j=0,i=0;
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		i++,j++;
		else
		{
			j=nexxt[j];
		}		
		if(j==m)
		{
			//返回你所需要的东西
		}
	}
	return ;//返回你所需要的东西
	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值