hdu 1358 kmp 最小循环节

 

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13151    Accepted Submission(s): 6144


 

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

 

Sample Input

 

3 aaa 12 aabaabaabaab 0

 

 

Sample Output

 

Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  3336 3068 2203 1277 1867

    传送门

思路:kmp+最小循环节
分析:
1 题目要求的是给定一个长度为n的字符串,求出字符串的所有前缀字符串中该字符串刚好由k个最小循环节够成,由于题目要求k最大那么就是这个循环节最小
2 只要先求出next数组,然后去枚举所有的前缀找到满足的输出长度和k

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define N 0x3f3f3f3f
using namespace std;
string a;
int nexxt[1000010];
void getnext()
{
	int i=0,j=-1;
	nexxt[0]=-1;
	while(i<a.size())
	{
		if(j==-1||a[i]==a[j])
		{
			i++,j++;
			nexxt[i]=j;
			int t=i-j;
			if(j&&i%t==0)
			{
				cout<<i<<" "<<i/t<<endl;
			}
		}
		else
		j=nexxt[j];
	}
}
int main()
{
	int n;
	int k=1;
	while(cin>>n)
	{
		if(n==0)
		break;
		cin>>a;
		cout<<"Test case #"<<k++<<endl;
		getnext();
		cout<<endl;//需要注意
	}
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值