hdu2141 二分查找

                **Can you find it?**

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 30503 Accepted Submission(s): 7594

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers
Output

For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

题目分析,首先想到的是 暴力写,三个for循环,时间复杂度为n^3,对于题目的数据来说 显然是TLE的,之后就想到二分;
具体是这样做的,枚举 Ai+Bj,之后二分查找X-Ck

代码如下:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<map>
using namespace std;

const int MAX = 510;

int a[MAX],b[MAX],c[MAX],d[MAX*MAX];

int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int l,n,m;

int find(int l,int r,int key){
    int mid;
    while(l<=r){
        mid = (l+r)/2;
        if(d[mid] == key)
            return 1;
        else if(d[mid]<key)
            l = mid+1;
        else
            r = mid-1;
    }
    return 0;

}
int main(void){
    int cnt = 0;
    while(scanf("%d %d %d",&l,&n,&m) != EOF){

        int dlen = 0;
        for(int i = 0 ; i < l;i++)
            a[i] = read();
        for(int i = 0 ; i < n;i++)
            b[i] = read();
        for(int i = 0 ; i < m;i++)
            c[i] = read();
        for(int i = 0 ; i < l ;i++){
            for(int j = 0 ; j < n;j++)
                d[dlen++] = a[i] + b[j];
        }
        sort(d,d+dlen);
        int x;
        x = read();
        printf("Case %d:\n",++cnt);
        for(int k = 0 ; k < x ;k++){
            int y;
            int f=1;
            y = read();
            for(int i = 0 ;i < m;i++){
                f = 1;
                if(find(0,dlen-1,y-c[i])){
                    printf("YES\n");
                    f = 0 ;
                    break;
                }
            }
            if(f)
 `
              printf("NO\n");
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值